Unable to edit code

Having problems editing code.
For example in the Drone Menace project we can add the background, drone, music, program the drone to glide across the screen and that’s all good.
When it gets to the section on duplicating the drones, we can do that, but we can’t then change any of the code on the drones. (.e.g to change the wait time)

In some of the other projects we’ve tried, including Turing’s Tower, which my son has done quite a bit of already, we cannot add any code blocks (e.g. dragging from the guided notes)

We’ve tried logging out and back in. We’ve updated Flash - today, still no luck.
He’s using Firefox on a Windows 10 PC.

I’m using Chrome on my PC and I don’t have problem, even logged in as him.

Apparently Firefox, and Chrome are both supported. So not sure what to do to help him now.

Would love some ideas on fixing this.

Apologies for the delay in responding - have you sent this to support@tynker.com? This seems very specific and they’ll need a bit more information to help you debug the issue. Tynker does not use flash but the project should work on Firefox.