Trouble Getting Started, Can't Get out of the Gate With Glitch Manor

Hello, My 7 yo son and I are new to Tynker and we’re not having much success getting started out, in particular starting with Glitch Manor, can’t get past adding the witches cauldron…which seems like it should be super easy. After adding ‘when actor clicked’ and ‘play sound’ code blocks, there doesn’t seem to be any way to proceed. We’re essentially stuck in on the page where you add the code blocks with no evident way to continue with the module. I’ve tried two different computers with different types of browsers so I don’t think it’s a technical problem with my computer(s). And it’s not just my 7 year old that can’t figure it out, I can’t either and I have an engineering degree, actual computer programming experience and multiple masters degrees. Any thoughts? Thanks in advance and sorry if I’m missing something totally obvious.

Have you tried the Answer keys available in your parent dashboard. If it is a technical issue, please send a note to and we’ll help you debug the issue.

We’re having the exact same problem in Goblin Quest. We’re stuck making the potions with the cauldron animation. It’s not a problem that can be solved with the answer key. The blocks are correct, but there is no way to proceed. What are we supposed to do after getting the blocks correct? Like the original poster, I have an engineering degree and 20 years experience designing computers and I can’t figure this out. So far, not impressed at all.